Posted by: Kai_LeRai | May 13, 2012

Asrock – The world’s worst motherboard manufacturer

Asrock sucks donkey ass! Now that that’s off my chest, let me explain. For the past 9 years I have been a frequent Asrock buyer. Whenever it came to assemble a new computer, either for friends, family or myself the price of it was always the main focus and if you want to go cheap, you’ll have to choose Asrock. That doesn’t mean that you also have to pass on new features. Asrock stacks even the cheapest boards with the newest and most sought after technologies, so you’re not missing out…or so you might think.

Once you hold the boards in your hands they don’t look any different from those of other manufacturers, but over time instabilities rear their ugly heads and that with a frequency that will make you doubt yourself. I have had issues with Asrock from day one up to now, but I have had it with them! I have decided to write up a chronology as a reference for myself, Asrock support which I will contact soon and others interested in the brand.

Before I start the list, let me express that cheap prices are not a free ticket for the manufacturer to produce non-functional or soon-to-break crap. I expect a durable product for the good money I pay just as with anything else I purchase. I’d expect support to be worse and the hardware with less features and less powerful in general, but there’s no reason to produce a shoddy product. Usually, this also isn’t a problem: cheap ass MP3-players, TVs, DVD-players household appliances – they all work well with one very rarely breaking. Same goes for the computer hardware I dealt with – with the exception of Asrock products.

Asrock K7VT2 (2003)

In 2003, I purchased the first board and ran into problems right after assembling the computer. Windows 98 ran extremely unstable and crashed upon putting the slightest load on it. Copying or deleting files was enough to make the system crash. I then tried to install Windows 2000, but during the installation Windows Setup told me that it couldn’t read certain files. To rule out a dirty disc, I copied the setup to HDD and ran it again. Same issue. A dirty medium couldn’t be the problem. CRC-comparing the files to the original disc also showed they were okay. I put so much trust into the board that I rules it out as a problem at first and installed Windows 2000 on another computer just to see if that would work. It did and that without trouble. For some reason, any data the board tried to handle was corrupted at some point.

I also tried to install Windows XP. Win 98 was old and Windows 2000 a server operating system, so may be they weren’t supported (even though logically that wouldn’t make any sense). Anyway, XP’s setup crashed with the dreaded “IRQL not less or equal” BSOD… Still not blaming the board, I switched the HDD from FAT32 to NTFS. XP was able to install now, but ultimately BSODed when installing all necessary drivers. Lastly, I installed a hard drive with a working windows and tried to boot from it and was greeted with an “INACCESSIBLE BOOT DEVICE” error. That’s when I decided to write up this story of suffering and send it to Asrock’s support.

Within 6 hours I received a reply which listed the following possible problems:

  1. Incompatible memory or timing problems
  2. Too long HDD-cable or broken cable
  3. PSU doesn’t deliver a stable 3.3V for the memory
  4. mainboard defective

My thoughts were:

2: I used a plethora of different cables. No way.

3: May be, but since I used three PSU to test the board with, that wasn’t very likely either.

4: That’s what I expected, hence my mail to Asrock.

1: I was instructed to flash my BIOS to rule out memory compatibility problems. I e-mailed the support twice telling them that my original BIOS version wasn’t available online and whether they could send it to me in case I’d have to down grade again.They never replied….

Seeing that I could rule out the other ideas the support had and that I didn’t expect them to e-mail me the necessary BIOS (haven’t received it after 9 years, so I guess I was right), I decided to stop the shenanigans and get rid of that board. I sent the board back to the retailer, who in return sent me the next best (= cheapest) Asrock replacement board he had available: an Asrock K7S8X. Suddenly, all problems were gone. All operating systems installed flawlessly…

Asrock K7S8X (2003)

Over the following two years the board developed instabilities that would make Windows XP and Windows 2000 (and later Windows 2003) crash at random with a BSOD. Despite switching out CPU, RAM, HDD, all cables and PSU, the crashes still occurred, leaving the board the only remaining factor. I should also mention that the computer equipped with this board was used by a friend who can best be described as occasional user. The work done on it was limited to browsing the web and writing documents. No overclocking, no hardcore gaming, folding or any other type of activity that pushes the limits of the hardware. That’s also why the faulty predecessor was chosen in the first place: It was cheap and perfect for a computer that would run only occasionally.

Ultimately, I replaced the machine with a new one based on an Asrock N61P-S (2009). That one’s still being used today in the same undemanding fashion. I actually wanted to switch manufacturers at this point, but the board I wanted to get was out of stock and the machine was to be picked up too soon so I couldn’t wait for a re-stock.

Asrock K7S8XE R3.0 (2004)

Having been impressed by the features of the K7S8X in comparison to the K7VT2, I decided to use an Asrock board for the first time for one of my own machines. I ignored the trouble I had with the K7VT2, because every manufacturer has a certain quota of defective hardware that finds its way to vendors, so I didn’t interpret anything into it. The board worked with 512MB RAM and an ATI Radeon 9600 and it’s still working to this day. I’d like to think that this is the rule, not the exception, but Asrock just makes it hard to see it that way.

Asrock AliveSATA2-GLAN (2007)

Three years later it was time for a new machine and since I hadn’t had any problems with my old board, I settled for the Asrock AliveSATA2-GLAN. It had everything I could wish for: SATA I + II support, a PCIe slot, 3 PCI-slots, support for Gigabit LAN, 1GHZ FSB, support for 8GB of RAM (huge back then, standard was between 1.5 and 2GB at that time), 7.1 Sound Chip, certified Vista compatibility, HDMI and SPDIF support and Hybrid Booster, which Asrock described as :”ASRock Safe Overclocking Technology”. It was supposed to be fool proof which I read as: “We have certain technology on this board to avoid damage done by OCing. It’s also extra stable that’s why we even built in this function”. So, in short, the board was perfect for me since I needed backwards compatibility for old hardware, but also the possibility to upgrade and overclock.

Asrock’s Hybrid Booster turned out to be a BIOS function that would overclock memory by 12.5%. And of course it crashed right after I activated it for the first time. I couldn’t boot up any more without experiencing crashes while Windows was loading. I also tried several memory modules of different manufacturers, including Kingston (can’t remember the other ones). None of them worked. That was a damper but no deal breaker. I was more bothered by the fact that the overclock could have been done on any board without giving it a BIOS shortcut and slapping a fancy name on it, but it shows the methods Asrock is working with.

I was using an ATI Radeon 1650 with this board. The card was passively cooled, so I attached a good active cooler and overclocked it, which pumped out some nice extra FPS for high settings of back then new games like Bioshock. After a couple of months, I started to experience BSOD crashes that named the ATI driver kernel as the failing component. At first I suspected overclocking to be the culprit, even though the card ran cooler OC-ed thanks to the attached fan than when run at stock speed with its passive cooler (I’m talking about 20°C difference here). Still, the crashes occurred constantly and with such frequency, that I was barely able to play games any more. The more demanding they got, the earlier the driver BSODed. This led me to believe that the graphics card or its driver was the culprit.

However, over time, crashes also appeared when watching videos. Sometimes the driver could be recovered by Windows Vista, but over time it got so bad that I wasn’t able to run any playback software without  an immediate crash. What also threw me off track when hunting the error was the fact that Windows XP behaved differently. It seemed more stable at first, but as soon as I started to work seriously in it, it crashed just the same. Even worse: it was basically never able to recover the display driver, so a cold reboot was the only solution out of these crashes.

While I endured the crashes, I tried to pinpoint the errors to something else, so I tested all the components as soon as I had the opportunity to switch them out: memory, HDD, cables, PSU, but to no avail. Eventually, I convinced myself that my overclocking endeavours were to blame and that my graphics card had gone overboard.  This culminated in the purchase of a new Palit Geforce GTX 260. After plugging it in and installing the drivers, I fired up 3D Mark 2006, leaned back and wanted to enjoy my newly bought stable and enhanced graphics performance, but it didn’t take longer than a minute for the next BSOD to occur. This time the NVIDIA display driver kernel crashed, making it obvious that this was not a driver issue, but one relating to the board. I was so pissed, about throwing so many hours of error tracking and so much money for new components into the gutter that I was about to smash that damn board, but since it was the only way to get a computing experience – flawed and unstable as it was – I pulled myself together and tried to avoid anything that would make the board less stable. Using the computer was like running through an obstacle course…in hell! Thanks to Windows Vista and later Seven this strategy worked. XP would usually lock up right away, but Microsoft’s new operating systems did a great job containing the damage of the unstable board by re-initializing failed drivers. All the more reason to not chime in with the senseless hate that they received and in parts still do.

At that point I decided to make the switch to another manufacturer. Easier said than done though. Checking for new boards, I decided to go with an onboard graphics chip to accompany my new GTX 260. I wanted to make use of NVIDIA’s Hybrid SLI which allows the system to switch between onboard GPU and dedicated graphics card to save power. Since I used my computer more for programming and much less for gaming that seemed to make sense. Also, the technology claimed that both GPUs could work in tandem with SLI-technology to boost the dedicated card. Having seen the power of the onboard GPU of the N61P-S, I was intrigued by the idea that a newer chip might prolong my graphics card’s life by a few years or at least give it the extra FPS which always seemed to lack to keep things stutter free.

Looking for a compatible board I quickly found the Asrock version of it. To my dismay all boards of other manufacturers cost almost twice as much. I found a retailer who offered a returned and probably repaired Asus M4N78 PRO GeForce8300 for the same price as the Asrock one. I was willing to prefer a used and repaired board (still had full warranty) over a brand new Asrock one. It turned out that the board was falsely labeled by the retailer and that it came with an ATI GPU and thus didn’t support NVIDIA’s Hybrid SLI. After two weeks of combing the web for alternatives in the same price range, I convinced myself that my bad experience with Asrock was just a fluke…a big coincidence and thus I decided on getting the only alternative:

Asrock K10N78

NVIDIA’s Hybrid Technology turned out to be less smooth as expected, but at least it did work and saved me quite some energy. The SLI-effect was practically non-existent. In fact, in SLI the performance was slightly worse while energy consumption skyrocketed. A couple of months after purchasing the board, NVIDIA silently dropped support for Hybrid SLI, effectively making the onboard GPU useless (unless they thought rebooting after playing a game to activate the onboard GPU in the BIOS was an option). At that point I regretted not having gotten the Asus board with the ATI GPU on it…

But just like Asrock’s Hybrid Boost this wasn’t a deal breaker, just an inconvenience. After installing all components to the board I fired up my monitoring and test software. I immediately recognized the ultra-high temperature of the onboard GPU. It ran at 130°C. Never having had an onboard GPU of my own, I wasn’t sure whether this was normal. A quick google search showed that many owners of this motherboard reported a temperature of 75°C as normal. I checked all components back and forth and then realized what had caused this behavior: The passive cooler for the south bridge – which also houses the onboard GPU – is so close to the PCIe-slot, that it actually touched the graphics card. That didn’t seem to be a problem, but the terrible board design caused the cooler to be lifted by only a millimeter, causing these insane temperatures. In fact, when I pushed down the cooler manually the temperature fell back to a “normal” 80°C within seconds. I was furious when I discovered this. How could any decent board manufacturer with half a brain create such an asinine board design?? It’s also worth mentioning that the passive cooler they used for the south bridge is the very same one they used for the ALiveSATA2-GLAN board, but that one didn’t have a freaking GPU to be cooled with it!

After it dawned on me that I had ended up with a crappy board again, I experienced more malfunctions: Hooking up an external USB drive resulted in frequent read errors which seemed to kick in as soon as the data rate went up. At first I thought the drive was damaged, but the supposedly unreadable data could be read back perfectly fine on other computers. Writing with high speed to the drive triggered the same error. The only thing that helps to even get the system out of a constant read attempt after it encounters an “unreadable” sector is to disconnect the drive, unplug its power and then plug everything back in. Also, certain parts on the drive seem to trigger the error, for example some files always seem to be broken and others always appear to be readable. As already stated, on other computers the drive works fine, so that only leaves the board. I wasn’t sure at first, though since I barely used the external drive and couldn’t rule it out as a source of error. I also didn’t want to think of having gotten another rotten board plus I was too busy to waste more time on this. Besides, everything else worked – so far.

After about a year more instabilities occurred: When watching a video, the screen froze, the audiotrack kept on running and the computer wouldn’t react any more. No key press triggered a reaction. Pushing the power button to induce a shutdown only made the HDD LED flash (and that with every press). Turns out every application that makes use of video overlays causes a screen freeze after a couple of seconds and that not just includes video playback software, but also Firefox and certain games such as Dead Space. Most games work though and so do Opera and IE (yuck). Thankfully, switching VLC’s output renderer from Overlay to Windows GDI prevents crashes.

At some point I upgraded my 5 year old CPU with an AMD 1090XT, the newest one that worked with the board. I had to realize that Cool’n Quit didn’t work. Without it, all 6 cores ran at full speed, even when the system was idle. Since it makes a huge difference whether you have 6 cores running at 3.2GHz or 800MHz, I re-installed Windows 7 and the proper drivers. It didn’t help. Once more, I contacted Asrock’s support and asked for help. Since I had already had a new Windows installed, the tech guy referred the case to his colleagues in Taiwan who had no problems at all. His advice was to re-install Windows.


Why would a re-install fix what a two day old re-install couldn’t?? It didn’t make any sense. In the meantime I had to re-install Windows and low and behold Cool and Quiet still doesn’t work. I’m just glad I didn’t waste any more time on the support’s moronic suggestion.

That’s it so far. After experiencing several freezes within minutes I decided to RMA the board and report my experiences here. It doesn’t matter whether Asrock fixes this problem or not: I will never EVER buy a fucking Asrock board again. After so many wasted days, after so many replaced components and after being inconvenienced time and time again I will make sure not to waste more money on this company. I’d rather sell a kidney to afford a board from a proper manufacturer than buy a single board from Asrock again.


%d bloggers like this: